Comments for Networking For Integrators http://networkingforintegrators.com Sat, 21 Feb 2015 08:02:00 +0000 hourly 1 http://wordpress.org/?v=4.1.1 Comment on How to run multiple networks from a Mikrotik by Russell Bach http://networkingforintegrators.com/2013/01/how-to-run-multiple-networks-from-a-mikrotik/#comment-35376 Sat, 21 Feb 2015 08:02:00 +0000 http://networkingforintegrators.com/?p=326#comment-35376 The article suggests from the picture of the winbox interface list that the default RB750GL configuration has been loaded. If you then make changes as suggested from the out of the box default configuration the subnets will not see each other(as you seemed to have experienced). You need to do a reset configuration and tick no-default and reboot and then rebuild with winbox as per above.

Otherwise if you have made changes from the out of the box default configuration you will need to add to ip firewall nat

add action=masquerade chain=srcnat comment=”to allow ping to subnet” out-interface=!ether2-master-local src-address=192.168.2.0/24
add action=masquerade chain=srcnat comment=”to allow ping to subnet” out-interface=!ether3-slave-local src-address=192.168.3.0/24
and so on for each ether port and subnet
and then should be able to ping each subnet. I did document this previously but the other 33 posts to this thread have vanished.

]]>
Comment on How to run multiple networks from a Mikrotik by Beastly Bee http://networkingforintegrators.com/2013/01/how-to-run-multiple-networks-from-a-mikrotik/#comment-35230 Tue, 13 Jan 2015 14:59:00 +0000 http://networkingforintegrators.com/?p=326#comment-35230 Nice article, I’ve been researching the last part which is to make the different networks talk but no luck. I’m testing two networks they can ping each interface ip but no the computer connect to those interfaces. Any suggestions?

]]>
Comment on Mikrotik – how to change the default DHCP range by Scott Waters http://networkingforintegrators.com/2012/11/mikrotik-how-to-change-the-dhcp-range/#comment-35183 Thu, 18 Dec 2014 22:15:00 +0000 http://networkingforintegrators.com/?p=238#comment-35183 for my future reference. last step is IP->Addresses

]]>
Comment on Your Wi-Fi Sucks by TonyNoOne http://networkingforintegrators.com/2014/11/your-wifi-sucks/#comment-35179 Tue, 16 Dec 2014 18:59:00 +0000 http://networkingforintegrators.com/?p=558#comment-35179 That’s good stuff. I’ll bet the fella who wrote it is just as handsome as he is charming.

]]>
Comment on How to run multiple networks from a Mikrotik by Hamish Lockhart http://networkingforintegrators.com/2013/01/how-to-run-multiple-networks-from-a-mikrotik/#comment-35151 Mon, 17 Nov 2014 04:11:00 +0000 http://networkingforintegrators.com/?p=326#comment-35151 Really nice article. I was confused that I couldn’t ping a machine on a different network. Turns out I didn’t have the default gateway setup on the receiving machine.

]]>
Comment on Changing the incoming port for port forwarding on a Mikrotik by Ggggg22 http://networkingforintegrators.com/2012/11/changing-the-incoming-port-for-port-forwarding-on-a-mikrotik/#comment-35120 Sun, 09 Nov 2014 22:00:00 +0000 http://networkingforintegrators.com/?p=219#comment-35120 ??????? ????????, ?????? ?? ????????

]]>
Comment on Hairpin NAT – or how to use your DynDNS address internally or externally by admin http://networkingforintegrators.com/2013/02/hairpin-nat-or-how-to-use-your-dyndns-address-internally-or-externally/#comment-35100 Tue, 04 Nov 2014 00:26:35 +0000 http://networkingforintegrators.com/?p=363#comment-35100 If you put it at the very end of the script and it doesn’t run, there must be some kind of syntax error (I would think). You can go in Terminal and it’ll give you some clues as to if there’s a syntax error in the script somewhere. Go to /system scripts and do “print brief”. It’ll give you a list of all your scripts with a number next to it. Let’s say that it’s #3. Type “print from=3″ and it’ll print out the whole script (it’s long, so it won’t fit on one screen and you can scroll up/down, quit, etc).

If there’s a syntax error in the script, the character where the error is should be “highlighted” and show you what part the system doesn’t understand.

You can also try running the script from Terminal and it might output an error to give you some ideas as well.

Also, you can add some “debugging” stuff into the script to track where it’s failing. Like:

:put message=”about to run hairpin_updater”
/system script run hairpin_updater
:put message=”hairpin_updater should have just run”

Then run the script from Terminal

]]>
Comment on Hairpin NAT – or how to use your DynDNS address internally or externally by rich http://networkingforintegrators.com/2013/02/hairpin-nat-or-how-to-use-your-dyndns-address-internally-or-externally/#comment-35076 Sat, 01 Nov 2014 12:09:45 +0000 http://networkingforintegrators.com/?p=363#comment-35076 I reset the router completely and re-did everything. It works now.

The only thing I still cannot get to work on multiple routers is the dyndns script running the hairpin updater. I have to use a separate scheduler to run it.

I placed it exactly where you state to, I also tried it at the end of the script but the dyndns script never runs the hairpin updater script.

]]>
Comment on Hairpin NAT – or how to use your DynDNS address internally or externally by admin http://networkingforintegrators.com/2013/02/hairpin-nat-or-how-to-use-your-dyndns-address-internally-or-externally/#comment-34892 Thu, 09 Oct 2014 23:54:45 +0000 http://networkingforintegrators.com/?p=363#comment-34892 Are you doing double-NAT? (e.g. is the Mikrotik plugged into another router?)

]]>
Comment on Hairpin NAT – or how to use your DynDNS address internally or externally by admin http://networkingforintegrators.com/2013/02/hairpin-nat-or-how-to-use-your-dyndns-address-internally-or-externally/#comment-34891 Thu, 09 Oct 2014 23:52:31 +0000 http://networkingforintegrators.com/?p=363#comment-34891 It was a bad cache setting on my end. For some reason it was only affecting that page, but should be good to go now (and for a while now)

]]>